2017/09/01

O caso do travessão nos teclados dos Huawei


Por muitas décadas de experiência que se tenha a lidar com as coisas da informática, há sempre casos insólitos que continuam a surgir, e desta vez foi um estranho caso que estava a impedir a introdução de uma conta de email num smartphone da Huawei... e a culpa era do teclado.

Tudo começou com um pedido de ajuda no nosso grupo de discussão, referente à impossibilidade de não conseguir introduzir uma conta de email num Huawei Y6, aparentemente porque a existência de um hífen no nome do domínio desactivava o botão de "SEGUINTE". Removendo o tracinho  do nome o botão já voltava a activar-se... e como tal, a culpa estava a ser apontada para o Android 6.0 que vem neste smartphone.

Mas rapidamente outros relembraram que tanto o hífen ("-") como o underscore ("_") são perfeitamente válidos para serem usados em emails, pelo que o problema deveria estar relacionado com qualquer outra coisa... E na verdade assim era: a culpa era do teclado.


Na verdade, o caracter que estava a ser introduzido não era um hífen mas sim um travessão ("—"), sendo a pessoa induzida em erro por esse travessão estar em lugar de destaque no teclado (Swype) usado neste Huawei - mesmo quando na realidade se trata de um caracter de utilização bastante rara, ao ponto de nem sequer estar presente nos teclados PT (físicos) - roubando protagonismo ao hífen, que está localizado ao lado da pequena tecla de espaço.

É um erro que pode parecer inconsequente - depois de se saber o que é - mas a verdade é que originou alguns dias de frustração a várias pessoas; e fica aqui o relato para que eventualmente possa ajudar alguém que passe pelo mesmo problema de dificuldade em associar uma conta de email com hífen num Android.

Uma estranha opção deste teclado, apresentar um caracter pouco utilizado e que pode induzir em erro, quando haveria outros caracteres bem mais úteis que poderia exibir (como o "%" ou "*") na sua posição.

1 comentário:

  1. Aconteceu a mesma coisa cmg quando tive de meter a password do wifi pela 1ª vez. Dava sempre erro. No inicio resolvia com o wps, mas achava estranho pq metia a mesma pass no iphone e dava e metia no huawei e dava erro. Até que vi o tracinho ao lado da virgula :)

    ResponderEliminar

[pub]