2019/02/24

Android vai começar a alertar quando se instalam apps antigas


Para minimizar os riscos de segurança, a partir de Agosto deste ano os utilizadores começarão a ver alertas no caso de tentarem instalar apps criadas para versões mais antigas do Android.

A Google muito se tem esforçado por manter a plataforma Android segura, melhorando-a de versão para versão, mas muitas vezes essas melhorias são traídas pela necessidade de se manter a compatibilidade com as versões anteriores do sistema. Apps que em versões mais recentes do Android teriam mais dificuldade em obter determinadas permissões, podem muitas vezes contornar esse facto ao serem compiladas para versões anteriores do Android, que não faziam tantas exigências a esse nível.

Para combater essa táctica, a partir de Agosto a Google utilizará o seu serviço Google Play Protect para alertar os utilizadores quando tentarem instalar uma app feita para versões mais antigas do Android. Algo que se revela de importância crítica quando a própria Google diz que 95% do spyware conhecido em Android é feito para versões ultrapassadas do Android, para se aproveitar da falta de permissões.

A partir de Agosto deste ano, instalar uma nova app que não tenham sido feitas - pelo menos - para o Android 8.0 Oreo irá gerar um desses alertas; e em Novembro o alerta será expandido também às actualizações de apps já instaladas. No ano seguinte a versão mínima exigida será o Android 9.0 Pie, e assim sucessivamente, de ano para ano.

Para os developers, a partir de Agosto só poderão enviar novas apps para a Play Store que tenham sido feitas para o Android 9 Pie; e em Novembro, também as actualizações de apps existentes terão que seguir essa regra.

Sem comentários:

Enviar um comentário (problemas a comentar?)

[pub]