2010/02/02

Giada Cube N3

Finalmente tive oportunidade de fazer alguns testes ao meu recém adquirido Giada N3 Barebone.


Relembrando-vos as características:

Giada Cube N3
  • Processor - Intel® dual-core ATOM™ N330 1.6GHz
  • GPU - nVidia® Ion
  • Memory - DDR2-800 SO-DIMM (Max. 4GB)
  • Harddisk - SATA2 2.5" HDD (Max.500GB)
  • Output - 5 ×USB2.0, E-SATA, 1×Card Reader (SD/SDHC/MMC), 1×HDMI 1×DVI-I
  • LAN - Ethernet 100/1000M + WiFi
  • Audio - Stereo Audio In/Out and S/PDIF
  • Power consumption - 23W
  • Size - 194mm×136mm×55mm
  • Color - Black, silver

O seu funcionamento geral revela-se bastante fluido e aceitável (no meu caso pessoal optei por instalar-lhe 2GB de Ram, e um disco 2.5" de 7200rpm.


Embora não vá ser o seu propósito, comecei por ver que tal se comportava no papel de "media center" e medir a sua utilização com vídeo de alta definição:


Ver vídeo 720p ou 1080p com aceleração por hardware (DXVA no Windows) não é problema - tendo apenas tido alguns problemas com clips 1080p a 22Mbps, que estranhamente "encravavam" o media player classic (embora o vídeo continuasse a dar.) A utilização do CPU variava entre os 10% e os 50% no caso dos 720p, e por vezes chegavam aos 70% nos 1080p.
(Esta utilização incluia o CPU gasto nas transferência WiFi.)

Já em Flash... ficou demonstrada a necessidade de este rapidamente necessitar de aceleração por hardware, já que vídeo a 720p rapidamente chegava aos 70-80% de utilização do CPU, e atingindo os 100% em "fullscreen".

A grande surpresa (e desilusão) foi quando fui verificar os consumos:
45 Watts em "idle".

Ora... bastante distante dos 23W anunciados - o que me faz suspeitar que algo esteja "mal configurado" e a causar este consumo exagerado.

Suspeitas que são "confirmadas" pelo consumo que se mantém constante quer o computador esteja em idle, ou em carga, a ver vídeos ou não, ficando sempre nos 45W medidos.

Perdi alguns minutos a brincar com os modos de poupança de energia... mas não tive tempo para analisar o que pode estar a causar isto.


Com o computador em "suspend" normal, com o hardware todo ligado, o computador efectivamente aproxima-se do valor que deveria ter em "idle": 18W.
Este seria o valor que esperava ver com o computador em funcionamento sem estar em carga - recaindo a minha suspeita sobre a placa gráfica/ION... já que o disco de 2.5" apenas deverá representar alguns poucos Watts.

Activando o modo S3, que coloca o computador em modo "sleep" total, o consumo desce para os 2 Watts.


Terei que perder mais tempo para analisar a causa daquele consumo excessivo (e fazer medições com sistemas operativos alternativos e com Live CDs.)

37 comentários:

  1. algum driver n adequado pode ser a causa.
    coisa boa em linux: $ sudo powertop

    ResponderEliminar
  2. Eu bem tento arranjar tempo para poder brincar com tudo isso mas... o tempo insiste sempre em escapar-se.
    :)

    ResponderEliminar
  3. Se o objectivo não é media center qual é já agora? :p

    ResponderEliminar
  4. metro um servidor domestico com baixo consumo energetico

    ResponderEliminar
  5. Carlos, Muito obrigado pela informação. Esses valores quando comparados com os meus 69W com um XII 240 em undervolt/clock (1030/0,8v) , nvidia 8300 integrada, 2gb ram mais 2 discos sata, já não justificam a troca.

    ResponderEliminar
  6. @Luis

    Isso é um AMD? (o 240 está-me a baralhar)

    Usas Linux? Podes fazer um benchmarkting para comparar com o meu 5050e que gasta pouco menos que o teu. Tenho curiosidade em compara um processador preparado para gastar menos com um mais potente e undervolt/clock.

    ResponderEliminar
  7. Ah já vi qual é, pois já é outra evolução, mais cache, etc a comparação não é justa mas mesmo assim deve ser interessante.

    ResponderEliminar
  8. @Luis

    Como disse, há algo que está ali a falhar... durante o boot (e quando se está na BIOS) aquilo gasta efectivamente os 20W. Mas a meio do arranque do Windows aquilo salta para os 40W e mantém-se lá.
    Vou ter que fazer mais testes (e medir os consumos com Ubuntu, etc.) para ver se descubro a causa.

    ResponderEliminar
  9. @metRo_

    O objectivo principal seria ficar este PC como "sempre-on" como servidor central, pastas partilhadas, logging dos consumos da casa, etc.

    ResponderEliminar
  10. A mim parece-me que esse salto para os 40W e mesmo apartir da + utilização do CPU/GPU e disco.

    Mas mesmo assim é bom, este tipo de aparelho para mim só mesmo para Media-Center (Xbmc)...

    Para pastas partilhadas e servidor web e etc, um NAS dedicado e muito melhor Carlos :)

    ResponderEliminar
  11. Um NAS dedicado será melhor, sem dúvida... mas até que apareça um que permita 4 ou 5 discos a preços que não sejam "roubalheira", vou mantendo um PC nessa função - acumulando igualmente outros papéis, obviamente. :)

    Por acaso nem faço ideia de quanto esteja a gastar o PC que actualmente mantenho sempre ligado (com Ubuntu)... Porque como está sempre em uso nem me dá oportunidade de lá por o medidor de consumos. :)

    ResponderEliminar
  12. Carlos, isso não precisará de um software que faça baixar o processador? Tinha a ideia que em windows é preciso, não basta o driver.

    ResponderEliminar
  13. @Nuno

    À partida, pensava que o Windows fosse suficientemente inteligente para fazer isso...
    Experimentei até colocar no modo de "máxima poupança", mas não fez nada.

    As opções de throttling do CPU também não estavam disponíveis (noutros CPUs pode-se definir uma percentagem de funcionamento.)

    Mas... as minhas suspeitas recaem sobre a gráfica. O CPU por si só não explica que o consumo passe para o dobro (ainda para mais, quando está a "0% de utilização")

    ResponderEliminar
  14. @Nuno,

    Que tipo de Benchmark tinhas em mente? Posso te dizer que o CPU dá 3780Mhz com 270FSB e passa a 90W em idle

    ResponderEliminar
  15. @Carlos,
    Vê no controlo do driver a velocidade a que está o gpu e tenta baixar. se não der, instala a o software da nvidia (actualmente estou por fora disso, dantes era rivatuner e afins...)
    Eu instalei para ver na minha 8300( mas foi para overclock, lol)

    ResponderEliminar
  16. Pois... é o que irei fazer quando tiver tempo para lhe por as mãos em cima novamente.
    Pensei que aquilo viesse "de fábrica" afinado para a eficiência energética... mas parece que não.

    ResponderEliminar
  17. @ Luis Costa

    Como sou utilizador de Linuz tinha de ser um programa de linux como o HardInfo 0.5c

    ResponderEliminar
  18. OK, então vou experimentar e depois logo digo qq coisa. Parece ser o Everest do Windows

    Podes me contactar por email para obter mais informações sobre este assunto.

    ResponderEliminar
  19. @Carlos se quiseres experimentar o XBMC live vê esta versão especialmente desenvolvida para as plataformas ION, possui também alguns extras muito interessantes :)

    http://www.xbmc.org/forum/showthread.php?t=66388

    ResponderEliminar
  20. Thanks! Quero experimentar pois! :)

    ResponderEliminar
  21. Carlos,

    só para dizer que o XBMC já permite recorrer ao DXVA do W7. Impecável.

    Como são as temperaturas do teu processador?

    Cumps

    ResponderEliminar
  22. Vou fazer o comparativo com o o!play este fim de semana. :)

    ResponderEliminar
  23. Anónimo7/4/10 15:18

    Se alguem tiver conseguido instalar o osx neste brinquedo apite, já que o comprei com esse objectivo e apesar de n ser totalmente newbie, n consegui e tenho a máquina encostada :( obrigado!

    ResponderEliminar
  24. E então sempre conseguiste por isso a gastar menos energia? Encontrei estas coisinhas aqui na loja do lado agora... a Niposom. 168 EUR.

    ResponderEliminar
  25. @Edgar

    Não... confirma-se que o consumo se fica pelos 45W. Os "20W" anunciados é num qualquer modo de suspend (como eu uso o S3-STR, fica em standby a poupar ainda mais.)

    ResponderEliminar
  26. Viva Carlos,
    Passados uns meses a usar a máquina o q podes dizer dela? Estava a pensar em comprar uma para media-center.

    :)
    BL

    ResponderEliminar
  27. @BL

    Estou muito satisfeito com a máquina - no entanto neste momento ando a tentar arranjar tempo para resolver um problema que surgiu recentemente.

    Os videos 1080p agora são reproduzidos "aos saltos" - os mesmos vídeos que nos testes que fiz no início tocavam perfeitamente.

    Não sei se terá sido alguma atualização da placa gráfica ou de um codec que terá lixado alguma coisa. Estou para analisar isto, mas não tenho tido tempo. :(

    ResponderEliminar
  28. Obrigado pelo feedback :) Acho que vou mesmo encomendar o meu para se sentar ao pé da minha TV :)

    ResponderEliminar
  29. Boas. Preciso que me confirmem se o equipamento possui um slot livre para adicionar uma placa de tv? Abraços!

    ResponderEliminar
  30. Slot para placas extra, não tem.

    ResponderEliminar
  31. Carlos, eu sei que devo estar a te "chatear" mas podia me esclarecer se este barebone tem compatibilidade ao seguinte equipamento um disco IDE de 7400 RPM de 3,5 e memória RAM de DDR-PC2700? É saber se posso ou não dar uso ao equipamento antigo e sem uso actualmente.

    ResponderEliminar
  32. O disco tem que ser de 2.5" para caber lá dentro, e a memória tem que ser uma SO-DIMM DDR2.

    ResponderEliminar
  33. Ola Carlos.
    Desculpa o desenterro, mas ando a procura de um nettop, para fazer de HTPC (XBMC/WMC) e Servidor (HTTP, FTP, Backup).
    Queria saber se a maquina aguentaria com processos de fundo como http server, utorrent e ao mesmo tempo desse pa ver filmes em 720p?
    E já agora, que refrigeração usa, passiva? Se não, faz muito barulho, para se ter na sala?
    Obrigado, e desculpa pela maçada :P

    ResponderEliminar
  34. @3dK©
    Sim, uma coisa deste tipo dá perfeitamente para isso. O vídeo tem aceleração por hardware (ION) pelo que não ocupa demasiado CPU, e permite aguentar em background com os outros serviços que precisares.

    Este Giada tem uma ventoinha no CPU, mas é relativamente silenciosa (ainda considerei a hipótese de a trocar por uma "silent", mas o barulho que se ouve é mais do próprio ar a passar pelos orifícios de refrigeração na caixa - pelo que deixei ficar com a ventoinha de origem.) Num caso normal, a mais de 1m de distância ou na sala para usoi normal, é perfeitemente "silencioso". :)

    ResponderEliminar
  35. Apenas teem um slot SO DIMM ?

    ResponderEliminar
  36. Errr... tenho ideia que sim, que era só um slot (para confirmar agora, só abrindo - mas tenho-o num sítio que não dá muito jeito para isso. :)

    ResponderEliminar

[pub]